Web lists-archives.com

Re: Latest Git-2.12.2 cannot install python packages for pip




On Tue, May 02, 2017 at 06:52:40PM -0600, Doug Henderson wrote:
> On 2 May 2017 at 13:06, ankostis wrote:
> > On Windows, with Cygwin-git 2.12.2 the python command:
> >
> >     pip install git+https://github.com/...
> >
> > fails to work with the following error:
> 
> 
> I suspect you have a windows version of python ahead of the cygwin
> version in the path. At least that is how it looks from the output of
> "cygcheck -s -v -r" you provided.

To close the loop, since this has also been discussed on the Git mailing
list: yes, ankostis was attempting to use Cygwin Git with Windows
Python.  As far as I'm concerned, this isn't a supported scenario; if it
worked with Git v2.8.3-1, that was coincidence rather than by design.

As such, I'm not going to investigate this further.  I am willing to
spend a little time helping others investigate, however, and I'm willing
to apply patches to the Cygwin Git builds to resolve/remove this sort of
problem, provided they've been at least tentatively accepted for future
application to the upstream Git source code.

Adam

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple