Web lists-archives.com

Re: Latest Git-2.12.2 cannot install python packages for pip




On 2 May 2017 at 13:06, ankostis wrote:
> On Windows, with Cygwin-git 2.12.2 the python command:
>
>     pip install git+https://github.com/...
>
> fails to work with the following error:


I suspect you have a windows version of python ahead of the cygwin
version in the path. At least that is how it looks from the output of
"cygcheck -s -v -r" you provided.

To confirm, please issue the following commands in your cygwin terminal window:

python --version

pip --version

git --version

The following commands may also help to confirm this and find the
executables you need to use:

which -a python

which -a pip

which -a git

/usr/bin/python --version

/usr/bin/pip --version

/usr/bin/git --version

Also, note that Python 3.6 on cygwin is named python3 and it uses pip3
for installing packages.

HTH
Doug

-- 
Doug Henderson, Calgary, Alberta, Canada - from gmail.com

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple