Web lists-archives.com

Re: Another BLODA with Cylance PROTECT? Can't rebase




On Apr 19 14:25, Timothy McDaniel wrote:
> I'm setting up a new Windows machine, and as usual, hitting a problem with
> installing Cygwin.
> 
> setup-x86_64.exe.  Package postinstall shows
> 
> Package: 0/Perpetual
> 	0p_000_autorebase.dash exit code 2
> Package: _/Unknown package
> 	base-files-mketc.sh exit code 254
> 	base-files-profile.sh exit code 254
> 
> "cd /etc/postinstall" and running by hand in ash shows
> 
> $ ./0p_000_autorebase.dash
> creating empty /var/cache/rebase/rebase_pkg
>       0 [main] dash 12952 fork: child 12912 - died waiting for dll
> loading, errno 11
> /bin/rebaselst: 98: /bin/rebaselst: Cannot fork
> $ ./base-files-mketc.sh
>       0 [main] sh 13628 fork: child 10276 - died waiting for dll loading,
> errno 11
> ./base-files-mketc.sh: fork: retry: Resource temporarily unavailable
> ...

That's pretty bad, considering that ash only links against the Cygwin
DLL itself.

> Running /bin/rebaseall by hand, the old way, had no output and no
> effect.

No effect?  How do you know?  Check the output of `rebase -si'.  The
DLLs shouldn't overlap, Did you run /bin/rebaseall from ash?
Other than that, if you have the file, rebaseall did its job, at least
for the DLLs not in use at the time (i.e., when running bash,
libreadline for instance).

> The new laptop has Cylance PROTECT on it.  It might be BLODA ... but
> it's not on the BLODA list, and I tried setting "export
> CYGWIN=detect_bloda" but the output doesn't change.

We just don't (and can't) know all BLODAs, and the bloda detection
was just a nice try.  It doesn't seem to catch a lot of culprits.

> There might be
> some other BLODA that I don't know about.  BTW, it's a work laptop and
> thoroughly locked down, so I can't change any settings for it.
> 
> Did I miss something in Web pages?  Any suggestions on how I might
> proceed?

If rebaseall did its job as outlined above, you should be mostly good to
go.

Talk to your admin guys.  If you're sure Cylance PROTECT is the culprit,
you (or your admins) may want to talk to their support.  We can also add
it to the BLODA list then for others encountering the same problem.


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Attachment: signature.asc
Description: PGP signature