Web lists-archives.com

Latest 64 bit cygwin miscompiles gawk master




Hi.

I just did a fresh install of the 64 bit cygwin on a new Windows 10
computer.  I am trying to build gawk from git master and getting
failures. It looks like something is being miscompiled in the NODE
union. Compiler is GCC 5.4.  I have no problems with this compiler
on Ubuntu 16 or with GCC 4.9 on an older 64 bit cygwin.

Also, when running configure, there are a lot of errors about not
being able to remove conftest.exe, device or resource busy, which I do
not get on the older Cygwin.

Repeat by

	git clone http://git.savannah.gnu.org/r/gawk.git
	cd gawk
	./bootstrap.sh && ./configure && make -j && make check

Watch several of the checks crash and burn

Interestingly enough, compilation of the released gawk-4.1.4 tarball
goes off without a hitch; the test suite runs to completion with
no problems.

Please help.

Thanks!

Arnold

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple