Web lists-archives.com

Re: Numpy 1.12.1 setup issue (targetting Python 3.6.1) from Cygwin 2.8.0




On 4/16/2017 7:37 AM, Kptain wrote:
Yes, but as I said, the problem is this step was already done:

"I would add that python3-numpy package was added when I have selected
cygwin package for setup".

For me the problem is to identify clearly other cygwin packages required as
dependencies are not already highlighted by cygwin setup.

Concerning Python3 packages installed, PIP is done for that and is working
well.
I have already used for Py packages used pure python source code: no
problem.

However for Py libraries involving C source code or having some graphics
dependencies, the problem is different: it is exactly the issue I'm facing
with numpy.
I could have added same kind of issue with matplotlib.

I am sure someone else will correct me if I am wrong, but you
need the Cygwin versions of these, not the Windows or Linux
versions.  I suspect PIP does not fetch Cygwin versions, thus
you must acquire these via setup.  However, they are not
required for base python, so you have to request them explicitly
in setup ...

An alternative is to build them from source yourself under Cygwin,
which I seem to recall doing at some point ...

Regards -- EM

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple