Web lists-archives.com

XWin focus in multiwindow mode




I noticed that a few apps don't manage focus properly when running under XWin.

Summary:
Given a focused X11 app, focusing a native Windows window, the focus is not lost in the X11 window.

Steps to reproduce (with terminator):
- Start terminator under XWin with multiwindow window manager
- Focus a Windows window by clicking on it

Expected behavior:
- Focus should be lost from the terminator window

Actual behavior:
- The terminator window remains focused. (by focused I mean that the caret remains plain, and the titlebar remains in the focused color, the windows properly lose keyboard focus and other OS level focus) - Also, if I open a menu (in android studio for example), and click a Windows window, the menu remains open.

Notes:
If I click another X11 windows, the focus is properly lost. It only happens if I pass the focus from an X11 window to a native Windows window.

I tested a few X11 app, and not all have this behavior:

Working app:
- xterm
- git-cola
- st
- konsole
- chromium

Apps showing the bug:
- android-studio
- terminator
- gnome-terminal
- termite


Version:

			$ XWin --version 		
			Welcome to the XWin X Server 		
			Vendor: The Cygwin/X Project 		
			Release: 1.19.2.0 		
			OS: CYGWIN_NT-10.0 yoda 2.7.0(0.306/5/3) 2017-02-12 13:18 x86_64 		
			OS: Windows 10  [Windows NT 10.0 build 15063] (Win64) 		
			Package: version 1.19.2-1 built 2017-03-09 		

Started with.
			XWin -multiwindow -clipboard -silent-dup-error -listen tcp 		

--
Nicolas Goy
Programmer


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple