Web lists-archives.com

Very Slow Setup Parsing / was Re: Segmentation Faults




On Wed, 2/8/17, Marco Atzeri <marco.atzeri@xxxxxxxxx> wrote:

 Subject: Re: Segmentation Faults
 To: cygwin@xxxxxxxxxx
 Date: Wednesday, February 8, 2017, 1:31 PM
 
 On 08/02/2017 18:13, Ian
 Lambert via cygwin wrote:
 > FWIW, since
 doing the updates late last month, many programs are seg
 faulting for me, including XWin, wget, curl, ssh, procps,
 top, gawk...
 >
 > This is 64 bit on
 Windos 7 "professional."
 >
 > Below is excerpt from
 the end of a strace of wget http://www.yahoo.com/
 >
 > Is "windows
 error 2" easy to fix? :)
 
 Any bloda running around ?
 
 I will bet on some other program interfering on
 cygwin
 program execution or dll loading.
 ... 
 Check also if all the DLL needed by wget, curl,
 ssh, procps, top, gawk
 are still there. I
 saw case where the Antivirus removed the dll's
 without big notice.
 
= = = = =

There is probably lots of bloda around, but that was 
not the problem. I suspect incompatible versions of 
some things, because of the way I'd been updating
using apt-cyg following announcements. I started
chasing down DLLs and dependencies, but it was 
too slow manually. Now I have a new, different 
slowness automatically.

I've now downloaded a complete cygwin mirror
onto a networked storage, done a new install, and
cygwin works OK again. However, doing updates or
package installs is (1) extremely slow, and (2) giving
a below reported permissions problem.

(1) Slowness. After the setup initial steps and pointing
to the local install location, I get to the following display
for 10s of minutes to hours (see log excerpt farther down).
It eventually goes to the next step. There is a very
low, steady network traffic during the delay. This 
storage and network is usually fast for other things, 
including during actual package installs.

Is it searching through all the files in the mirror?

Can I change something to make this faster?

Setup Display:
Cygwin Setup (Not Responding) 
Parsing...
H:\home\...
100% (9704k/9704k)
Package: [static progress bar]

(2) I'm seeing the following error, and reporting as it 
suggests. It doesn't seem to 
cause any problem, but I can't change the permissions
(non-admin) to make it go away.

Package: _/Unknown package
        inetutils-server.sh exit code 1

check /var/log/setup.log.full and report any problems


2017/03/17 13:10:16 Starting cygwin install, version 2.877
2017/03/17 13:10:16 User has NO backup/restore rights
2017/03/17 13:10:16 Current Directory: H:\home\...\ftwin\mirror...\cygwin
2017/03/17 13:10:16 Could not open Service control manager
...

Rebuilding info directory
install-info: warning: no info dir entry in `/usr/share/info/abs_integrate.info'
install-info: warning: no info dir entry in `/usr/share/info/automake-history.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/automake-history1.12.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/automake-history1.13.info.gz'
install-info: warning: no info dir entry in `/usr/share/info/drawutils.info'
install-info: warning: no info dir entry in `/usr/share/info/kovacicODE.info'
install-info: warning: no info dir entry in `/usr/share/info/logic.info'
install-info: warning: no info dir entry in `/usr/share/info/maxima-index.lisp'
2017/03/17 16:32:18 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/mintty.sh"
2017/03/17 16:32:18 running: E:\cygwin64-3\bin\bash.exe --norc --noprofile "/etc/postinstall/inetutils-server.sh"
*** Warning: The owner and the Administrators need
*** Warning: to have .w. permission to /var/run.
*** Warning: Here are the current permissions and ACLS:
*** Warning:     drwxr-xr-x 1 myuser Domain Users 0 Mar 14 17:48 /var/run
*** Warning:     # file: /var/run
*** Warning:     # owner: myuser
*** Warning:     # group: Domain Users
*** Warning:     user::rwx
*** Warning:     group::r-x
*** Warning:     other:r-x
*** Warning:
*** Warning: Please change the user and/or group ownership,
*** Warning: permissions, or ACLs of /var/run.

*** ERROR: Problem with /var/run directory. Exiting.
*** Warning: The owner and the Administrators need
*** Warning: to have .w. permission to /var/run.
*** Warning: Here are the current permissions and ACLS:
*** Warning:     drwxr-xr-x 1 myuser Domain Users 0 Mar 14 17:48 /var/run
*** Warning:     # file: /var/run
*** Warning:     # owner: myuser
*** Warning:     # group: Domain Users
*** Warning:     user::rwx
*** Warning:     group::r-x
*** Warning:     other:r-x
*** Warning:
*** Warning: Please change the user and/or group ownership,
*** Warning: permissions, or ACLs of /var/run.

*** ERROR: Problem with /var/run directory. Exiting.
2017/03/17 16:32:26 abnormal exit: exit code=1

<snip>

Error connecting to currency server. <urlopen error [Errno 8] Name or service not known>

<snip>

2017/03/17 16:34:38 Ending cygwin install

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple