Web lists-archives.com

please allow specifying version when using command line installer




Right now, libxml2 version 2.9.4 has a bug (https://bugzilla.gnome.org/show_bug.cgi?id=766834) that causes perl XML::LibXML to fail to install (https://rt.cpan.org/Public/Bug/Display.html?id=114638).  Because of this, I need to ensure my team keeps the previous version 2.9.3.  In order to ensure consistent installs across my team I have an install wrapper (https://github.com/lucastheisen/cygwin-setup) which uses the command line installer to install the packages that are needed.  However, the command line installer appears to ignore versions.  I specified:

    "libxml2-2.9.3-1",
    "libxml2-devel-2.9.3-1",

But still ended up with version 2.9.4 (the latest) installed.  Am I doing something wrong or is this not supported?  If not supported, could it be added?

Thank you,
Lucas Theisen
ltheisen@xxxxxxxxx


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple