Web lists-archives.com

Re: [ANNOUNCEMENT] Updated: dash-0.5.9.1-1




On 02/23/2017 10:57 PM, Steven Penny wrote:
>> Or more likely, many people likely have pre-existing scripts wrongly
>> written as #!/bin/sh but which use bash-ism rather than portable
>> POSIX-specified shell
> 
> However, I think it is worth the trouble.

If you'd like, I can post experimental versions of both bash and dash,
which MUST be upgraded (or downgraded) in lockstep, where I move /bin/sh
over to the dash package (do it wrong, and you could be left with no
/bin/sh at all, which is not a good idea - although maybe I can use some
postinstall scripts so that at least the upgrade side tries to play nice
even when someone only does a partial upgrade).  If people will then
test with those experimental versions installed, and report breakage, we
could get a feel for how many scripts installed by default are broken.

But we are severely limited in volunteer manpower compared to Debian,
and I suspect that 1) there won't be enough testers (we won't know the
real impact until it is no longer experimental, but that is too late),
and 2) even if testers are diligent, we will be unable to patch all the
fallout in any sort of timely manner.

Are you really prepared to force the Cygwin community through that much
growing pain?

I agree that /bin/sh as dash is much faster at executing configure
scripts. But configure scripts aren't the only scripts in the wild. We
do have checkbashisms ported to Cygwin, and that can help, but it is not
a panacea.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature