Web lists-archives.com

Re: cppcheck 1.77 Segmentation fault (64-bit)




Jim Reisert AD1C wrote:
Best as I can tell, the seg fault is due to having installed the test
version of gcc 6.0.

I could reproduce the cppcheck segfault on 32-bit Cygin if libstd++6-6.3.0-1 is installed.

Possibly a variant of this problem:
https://cygwin.com/ml/cygwin/2017-01/msg00315.html

Downgrading /bin/cygstdc++-6.dll fixes the cppcheck crash.


  Even uninstalling gcc 6.0 does not fix the
problem.  I had to create an entirely new Cygwin-64 environment to get
past the problem.

Did you possibly miss to downgrade libstdc++6 package ?
It is not visible if 'gcc' is entered in the Search field of setup.exe.

Christian


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple